Server Unreachable

Hello, I have been trying to download dataset since this afternoon, but it kept failing due to server unreachable or network error (but the network works fine for other sites), what shall I do?

I can see successfully completed extracts on our end in your IPUMS USA account from today. Are you seeing the issues on the IPUMS website or when you try to download these to your machine or to shared network drive at your institution? It looks like you have included a number of full count datasets in your requests. Note that these files are quite large; it may take quite a while to download them over a wireless connection. From what I can see, the files have completed successfully. Please let me know if you are still not able to access your data extract requests.

Hello Kari, I came across these issues when downloading on my end. I have downloaded larger size before, but yesterday less than 1G cannot be downloaded.

And network error is not network disconnection. I tried disconnect and reconnect.