Data file (.gz) is corrupted (error code 32, "broken pipe"), and site won't let me redownload... Any suggestions?


#1

I attempted to download the Data file from my dataset, and it successfully downloaded the .gz file; however, when I try to extract it, it gives me the error “Unable to expand “usa_00001.dat.gz” into “IPUMS dataset 11-23”. (Error 32 - broken pipe.)”

I thought I might have interrupted the download or something, so I have tried to redownload the dataset, but it’s failed four times now when I’ve tried, including after logging out and logging back in.

Do I need to submit another dataset request at this point?


#2

I was just able to download, unzip, and open your data into STATA. Everything seemed to be working properly. So, unfortunately this doesn’t seem to be a problem on the IPUMS side of things. I wonder if the file is unzipping completely onto your hard drive. Perhaps check on the specific decompression software your computer is using to transform the .gz file into a .dta file. We typically find 7zip works consistently well.