.dat files won't unzip

I think there might be an issue with the .dat files that IPUMS is producing. My computer won’t allow me to unzip them. They’ve always worked in the past and I’ve tried resubmitted the abstract several times, unzipping via terminal, and scanning my computer for any viruses.

I had this problem too (on Mac). I found a solution by using Terminal to unzip the files with the command: gzip -d cps_00001.dat.gz

Hope this helps!

1 Like

I was able to download your latest extract and unzip it without issue. I recommend 7zip as a free decompression software if you are using Windows; the archive utility should take care of this on a Mac. There is a known known issues with Archive Utility decompressing certain .gz files for Mac users with the Catalina OS; you can get around this issue by using Terminal to navigate to the place where the .gz file is, and then entering

% gunzip cps_00081.dat.gz

If you are still not able to open the file, please follow up directly with ipums@umn.edu so we can troubleshoot this specific issue.