Could not find function "read_ipums_ddi"

Hi,
I installed all the updates that ipumsr requires, but then I got to the following error message:

library(ipumsr)
Error: package or namespace load failed for ‘ipumsr’ in rbind(info, getNamespaceInfo(env, “S3methods”)):
number of columns of matrices must match (see arg 2)
In addition: Warning message:
package ‘ipumsr’ was built under R version 3.5.3

And I keep receiving the same error message I have been receiving since I started:

ddi <- read_ipums_ddi(“ipumsi_00001.xml”)
Error in read_ipums_ddi(“ipumsi_00001.xml”) :
could not find function “read_ipums_ddi”

Help is appreciated!

What version of R are you using? I could be wrong but this looks like an issue that can be solved by upgrading R (see this stackoverflow post for a similar issue). According to the documentation, ‘ipumsr’ depends on an R package of 3.5.0 or greater.

I have a R version 4.0.3 (2020-10-10)

Thanks for the additional information. My first suggestion is to try reinstalling ipumsr with the following command:
install.packages("ipumsr")

If you continue to run into issues, we may be able to help troubleshoot if you share the output from the sessionInfo() command with us at ipums@umn.edu.